Table of Contents
Summary
Save time and effort previously spent manually answering custom questionnaires!
Smart Response automates the questionnaire response process using information from documents and previously completed questionnaires in your Knowledge Base and Trust Center(s). It is using the Whistic Artificial Intelligence (AI) algorithm.
Today's Prerequisites for the Smart Response are:
- Smart Response must be enabled; and
- You must have documents and questionnaires already loaded in the Knowledge Base and enabled for Smart Search.
- User Permissions Required:
- Knowledge Base / AI
-
Answer Self-Assessments / Edit Trust Center
- More information on user permissions can be found here.
- Whitelisting *.whistic.com
- More information on this can be found here
*Please contact your Whistic Customer Success Manager to start your journey with Whistic Smart Response.
๐ Ways to Start Using Smart Response
There are four ways to start using Smart Response:
- Option 1: Answer a questionnaire request from another Whistic customer which is most often found via an email link or in the Whistic Dashboard. For more on "How To Find a Questionnaire Request", click here.
- Option 2: Self-assess using a questionnaire. For more on best practices for Questionnaires, click here.
- Option 3: Map previously answered questions.
- Option 4: Import and respond to a questionnaire sent from outside of Whistic.
๐ Answer Whistic Questionnaires
(Option 1-3 above)
- Click into the questionnaire you want to answer from the email request, the Whistic Dashboard, or the Questionnaires page.
- Near the top of the questionnaire you will find a bar inviting you to "Use AI to answer this Questionnaire" and a button "Try Smart Response".
- Click on "Try Smart Response"
- Please note - You will lose answers if you have already added the information and then utilize smart response with auto accept. See FAQ below for more details!
- A window will appear to help you determine the following:
- The sources to use for answering the questionnaire:
- Knowledge Base - Use all the AI-enabled documents and questionnaires in your KB
- By Trust Center - Answer based on specific Trust Centers and just their contents, including the ability to use multiple Trust Centers
- Answering preferences:
- Tell AI to generate only High Confidence answers or add Medium Confidence as well
- Include comments or not as part of default answers
- The sources to use for answering the questionnaire:
- After Whistic AI generates the answers, you will have the opportunity to:
- Review and adjust the AI answers (if needed); or
- Answer any questions that AI was unable to answer
- Option 3: for previously answered questions, you will see a tag indicating it was a previous answer as seen below:
- Once you have finished completing and reviewing your answers, click on "Share Report" to send the completed questionnaire via Whistic, or click "Export" to save your responses (xlsx format).
๐ฅ Import and Respond to Questionnaires Sent From Outside of Whistic
(option 4 above)
This option automatically converts almost any spreadsheet into a custom questionnaire!
- Select "Knowledge Base" from the main menu
- Click the "Auto-Respond to Questionnaire" button in the right-hand corner.
- Follow the prompts to import the questionnaire. The Whistic platform can successfully assist with answering the following question types:
- Boolean (Yes/No)
- Multiple Choice/Answer
- Open Text
- Document Requests
- As the questionnaire loads, click the "Learn How" button in the bar "Use AI to answer this Questionnaire":
- A window will appear to help you determine the following:
- The sources to use for answering the questionnaire:
- Knowledge Base - Use all the AI-enabled documents and questionnaires in your KB
- By Trust Center - Answer based on specific Trust Centers and just their contents, including the ability to use multiple Trust Centers
- Answering preferences:
- Tell AI to generate only High Confidence answers or add Medium Confidence as well
- Users have the option to not include comments as part of Smart Response answers by removing the default checkmark next to "Include Comments"
- The sources to use for answering the questionnaire:
- After Whistic AI generates the answers, you will have the opportunity to
- Review and adjust the AI answers (if desired); or
- Answer any questions that AI was unable to answer.
- Once you have finished completing and reviewing your answers, click on "Share Report" to send the completed questionnaire via Whistic, or click "Export" to save your responses (xlsx format).
๐ง Troubleshooting
If Smart Response hangs or fails to process your questionnaire, this typically occurs due to file formatting issues. Follow these troubleshooting steps to resolve the issue.
Common Causes
Smart Response may hang or fail to process when:
- The file format is incorrect (must be: .xlsx, PDF, DOCX, CSV)
- The file contains multiple tabs
- The file includes non-question content such as instructions, definitions, or additional information
- The file structure is too complex for the AI to parse effectively
Troubleshooting Steps
If your questionnaire is not processing or continues to hang:
-
Verify the file format
- Confirm the file is an: xlsx, PDF, DOCX, CSV
-
Simplify the file content
- Clean up the document to include only the questions that need to be answered
- Remove formatting that may interfere with AI parsing (if needed)
- Ensure questions are clearly structured in a consistent format
-
Check your whitelisting settings
- If you haven't successfully used Smart Response before, whitelisting Whistic may be required
- Contact your IT administrator to ensure Whistic is whitelisted in your organization's security settings
-
Try uploading again
- After cleaning up the file, re-import it and attempt to use Smart Response again
Still experiencing issues? Contact Whistic Support at support@whistic.com for additional assistance.
๐ 'Filter By' Options
On each questionnaire you will see a Filter By icon on the upper right. This filter is to assist you in completing the questionnaire and sorting through questions like unanswered, Smart Response Ready (auto-accepted) and more. Here is a legend to help identify what each filter means:
- Smart Response Ready - This will show all Smart Response answers that were auto-accepted by the system due to strong confidence rating.
- Smart Response High - Questions that returned a High Confidence level, meaning the confidence is high because the answer is well-supported by the sources.
- Smart Response Medium - Questions that returned a Medium Confidence level, meaning the confidence is medium due to the sources returned.
- Smart Response Low - Questions that returned a Low Confidence level, where sources could not locate a definitive answer.
- Unanswered - No answer has been provided and/or the question has not been fulfilled (document upload, comments, answer selection, etc.)
๐ Reviewing AI-Generated Answers
The generated "AI Response" section includes - see picture above with the letter references:
| Item | Description |
|---|---|
| A | AI-generated responses are ranked with High, Medium, or Low Confidence to help you know how confident Whistic AI is that it found the right answer. |
| B | The AI response also includes a hint to show you how many sources were found to help answer this particular question. The source or sources can be reviewed in the side panel, after clicking on the question. |
| C | This is the AI-generated response. |
| D | You have the option to accept or reject the AI-generated answer. If the answer is Accepted, it is automatically populated in the response area above the blue box. The response can be edited, if desired, and changes will be automatically saved. |
| E (side panel) | When you click on a question, it opens a side panel where you can review the question or assign it to someone else. The side panel has three tabs: |
| E | Tab "AI Answers" provides information about the response. |
| F | Tab "Control Info" provides information about what the questionnaire creator is looking for in this response (if provided). |
| G | The button "Collaborate" provides an option to assign the question to someone else for review. |
| H | To review the AI-generated comment. |
| I | To have AI Provide an Answer Explanation (if desired). This is especially useful if an answer is "Unknown" but Whistic AI has identified relevant Sources. This may highlight incomplete or conflicting answers in your Sources. |
| J | To review the source(s) Whistic AI found to support this answer. |
| K | This button allows you to attach a file if needed. |
| L | By default, AI will automatically identify previously answered questions in the Smart Response answer. |
โ Completing a Questionnaire Response
As you automatically accept or manually answer questions, the progress bar (in green) at the top of the questionnaire continues to move to the right until it reaches 100% completion.
๐ Smart Response For Free Whistic Users
Free users of Whistic do have the ability to use Smart Response as well as paid users. In order to gain access, you'll start by locating the assessment you are trying to complete. Once you open the assessment, you'll see an option to 'Use AI to answer this Questionnaire':
You will click the 'Try Free' button in the screenshot above. Next, you'll see:
You will click the 'Yes' button and then you will see the below information. You can schedule a short call to speak with Whistic and verify some information, OR if preferred, you can email getaccess@whistic.com to request access to the free trial:
โ FAQ
Where do I load a customer questionnaire with my own answers?
- If you would like to upload an outside questionnaire provided by a customer or vendor, you can leverage our smart response feature from the knowledge base (auto-respond to questionnaire option) to create and answer the questionnaire. Once complete, you can share that report directly from Whistic.
- If the answer to a question is Unknown, click on the question. In the right side panel, review the Answer Explanation and the Sources (if available). This will highlight if you need to add or update sources in your Knowledge Base.
- For now, manually answer the question. Once the questionnaire is complete and you have reviewed all your answers, go to Knowledge Base and enable this questionnaire for Smart Search. This allows Whistic AI to use this questionnaire to help answer this question in the future.
- AI will only overwrite if you use Auto Accept. If you do not use Auto Accept, you can choose whether to use the AI answer or your original answer provided.
- It's possible there's a CORS error and that you have a network setting that is messing with CORS policies - most likely a network header change or origin swap. It is advised that you let your IT/Security team know that it is a possible CORS issue. It's possible your IT team changed network header settings.
- It could also be Zscaler or NetScope if your company utilizes Zscaler or NetScope for network settings. It could be running into the Zscaler/NetScope policy blocking Smart Response.
- It is strongly encouraged to whitelist Whistic with your IT/Security team as well by adding *.whistic.com to your internal network whitelist to ensure you can access all Whistic features. More info can be found HERE.
๐ What's Next?
After you have successfully completed the questionnaire, here are few items that occur or can be executed should you wish to share the information:
- Share or Export - After you review your responses, click "Share Report" to send the completed questionnaire via Whistic, or click "Export" to save your responses (xlsx format).
- Knowledge Base - Once fully completed, the new questionnaire responses will be automatically added to your Knowledge Base. Make sure they are enabled for Smart Search so that Whistic AI can use them as a more recent source of approved answers in the future.
- Knowledge Base Toggle to Exclude - To prevent a questionnaire from being included in future Knowledge Base searches or Smart Responses, simply do not enable the toggle next to the questionnaire name in the Knowledge Base. However, the more security documentation and more answered questionnaires you enable for Smart Search, the better Whistic AI will be able to answer future questionnaires, so we recommend enabling as much information in your Knowledge Base as possible. Learn more here.
- Whistic Trust Center - Completed standard questionnaires or custom questionnaires created by you can also be added to your Trust Center. Learn "How To Add a Questionnaire to Your Trust Center" here.